bluetooth

AirPods get stuck in low-quality 16 kHz audio mode when starting a VM

I always love when I find a really dumb solution that works reliably to fix a problem that should never really be a problem in the first place. But having worked with audio devices before—though nothing nearly as complex as the AirPods—I am willing to cut Apple some slack in building a seamless aural experience with using AirPods across phone calls, VOIP, iOS devices, Macs, music, and Apple TVs... it's hard to execute perfectly, and as I said in my review of the AirPods two years ago, these little earbuds are as close to perfection when it comes to a wireless sound solution for someone like me.

Anyways, here's the problem:

Sometimes (maybe 10% of the time) when I run vagrant up to build a local development environment for one of my software projects, and I'm listening to music, my AirPods suddenly switch into super-low-quality audio mode. It sounds like you're listening to a song played through a long subway tunnel or something.

How I discovered my left AirPod was bad

tl;dr: My left AirPod had some hardware issue. I got a new one. Now the AirPods work great.

The morning Apple's AirPods went up for sale, I was boarding a plane, and had just gotten to my seat on the plane. I knew they'd be in short supply (though I didn't know just how short—my local Apple Store only gets a small batch every week, and they're sold out in hours!), so I quickly ordered a pair, then set my iPhone in airplane mode for takeoff.

AirPods on Brown Paper
These things are awesome... though a little pricey.

2013 MacBook Air WiFi Problems (high latency, dropped connections) [Updated]

Update (3/4/14): Mac OS X 10.9.2 seems to fix at least the latency issue—and possibly dropped connections as well, at least for most users I've spoken with... We'll see!

Update 2 (11/25/14): If you're having trouble with iOS 8 and/or Yosemite, it could be related to AirDrop services over WiFi. Please see WiFried: iOS 8 WiFi Issue

For the past few months, I've been battling my 2013 11" MacBook Air's WiFi problems. I've taken the MacBook to the Genius Bar twice, and have attempted dozens of fixes. Judging by the number of individuals who have posted to this thread on Apple's Support Communities forum, among many other similar threads, I'm not the only MacBook Air owner suffering from WiFi issues like high latency, slow throughput, connection dropouts, and other random problems.

Here are some of the symptoms I and others have encountered:

Subscribe to RSS - bluetooth